This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class DSAPrivateKeySpec

java.lang.Object extended by java.security.spec.DSAPrivateKeySpec
All Implemented Interfaces:
KeySpec

public class DSAPrivateKeySpec
extends Object
implements KeySpec

This class specifies a DSA private key with its associated parameters.


Constructor Summary

          Creates a new DSAPrivateKeySpec with the specified parameter values.
 
Method Summary
 BigInteger

          Returns the base g.
 BigInteger

          Returns the prime p.
 BigInteger

          Returns the sub-prime q.
 BigInteger

          Returns the private key x.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

DSAPrivateKeySpec

public DSAPrivateKeySpec(BigInteger x,
                         BigInteger p,
                         BigInteger q,
                         BigInteger g)
Creates a new DSAPrivateKeySpec with the specified parameter values.

Parameters:
x - the private key.
p - the prime.
q - the sub-prime.
g - the base.
Method Detail

getG

public BigInteger getG()
Returns the base g.

Returns:
the base g.

getP

public BigInteger getP()
Returns the prime p.

Returns:
the prime p.

getQ

public BigInteger getQ()
Returns the sub-prime q.

Returns:
the sub-prime q.

getX

public BigInteger getX()
Returns the private key x.

Returns:
the private key x.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.