This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class ECFieldF2m

java.lang.Object extended by java.security.spec.ECFieldF2m
All Implemented Interfaces:
ECField

public class ECFieldF2m
extends Object
implements ECField

This immutable class defines an elliptic curve (EC) characteristic 2 finite field.


Constructor Summary
ECFieldF2m(int m)

          Creates an elliptic curve characteristic 2 finite field which has 2^m elements with normal basis.
ECFieldF2m(int m, BigInteger rp)

          Creates an elliptic curve characteristic 2 finite field which has 2^m elements with polynomial basis.
ECFieldF2m(int m, int[] ks)

          Creates an elliptic curve characteristic 2 finite field which has 2^m elements with polynomial basis.
 
Method Summary
 boolean

          Compares this finite field for equality with the specified object.
 int

          Returns the field size in bits which is m for this characteristic 2 finite field.
 int

          Returns the value m of this characteristic 2 finite field.
 int[]

          Returns an integer array which contains the order of the middle term(s) of the reduction polynomial for polynomial basis or null for normal basis.
 BigInteger

          Returns a BigInteger whose i-th bit corresponds to the i-th coefficient of the reduction polynomial for polynomial basis or null for normal basis.
 int

          Returns a hash code value for this characteristic 2 finite field.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

ECFieldF2m

public ECFieldF2m(int m)
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with normal basis.

Parameters:
m - with 2^m being the number of elements.

ECFieldF2m

public ECFieldF2m(int m,
                  BigInteger rp)
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with polynomial basis. The reduction polynomial for this field is based on rp whose i-th bit correspondes to the i-th coefficient of the reduction polynomial.

Note: A valid reduction polynomial is either a trinomial (X^m + X^k + 1 with m > k >= 1) or a pentanomial (X^m + X^k3 + X^k2 + X^k1 + 1 with m > k3 > k2 > k1 >= 1).

Parameters:
m - with 2^m being the number of elements.
rp - the BigInteger whose i-th bit corresponds to the i-th coefficient of the reduction polynomial.

ECFieldF2m

public ECFieldF2m(int m,
                  int[] ks)
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with polynomial basis. The reduction polynomial for this field is based on ks whose content contains the order of the middle term(s) of the reduction polynomial. Note: A valid reduction polynomial is either a trinomial (X^m + X^k + 1 with m > k >= 1) or a pentanomial (X^m + X^k3 + X^k2 + X^k1 + 1 with m > k3 > k2 > k1 >= 1), so ks should have length 1 or 3.

Parameters:
m - with 2^m being the number of elements.
ks - the order of the middle term(s) of the reduction polynomial. Contents of this array are copied to protect against subsequent modification.
Method Detail

equals

public boolean equals(Object obj)
Compares this finite field for equality with the specified object.

Overrides:
equals in class Object
Parameters:
obj - the object to be compared.
Returns:
true if obj is an instance of ECFieldF2m and both m and the reduction polynomial match, false otherwise.

getFieldSize

public int getFieldSize()
Returns the field size in bits which is m for this characteristic 2 finite field.

Returns:
the field size in bits.

getM

public int getM()
Returns the value m of this characteristic 2 finite field.

Returns:
m with 2^m being the number of elements.

getMidTermsOfReductionPolynomial

public int[] getMidTermsOfReductionPolynomial()
Returns an integer array which contains the order of the middle term(s) of the reduction polynomial for polynomial basis or null for normal basis.

Returns:
an integer array which contains the order of the middle term(s) of the reduction polynomial for polynomial basis or null for normal basis. A new array is returned each time this method is called.

getReductionPolynomial

public BigInteger getReductionPolynomial()
Returns a BigInteger whose i-th bit corresponds to the i-th coefficient of the reduction polynomial for polynomial basis or null for normal basis.

Returns:
a BigInteger whose i-th bit corresponds to the i-th coefficient of the reduction polynomial for polynomial basis or null for normal basis.

hashCode

public int hashCode()
Returns a hash code value for this characteristic 2 finite field.

Overrides:
hashCode in class Object
Returns:
a hash code value.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.