This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class ECFieldFp

java.lang.Object extended by java.security.spec.ECFieldFp
All Implemented Interfaces:
ECField

public class ECFieldFp
extends Object
implements ECField

This immutable class defines an elliptic curve (EC) prime finite field.


Constructor Summary

          Creates an elliptic curve prime finite field with the specified prime p.
 
Method Summary
 boolean

          Compares this prime finite field for equality with the specified object.
 int

          Returns the field size in bits which is size of prime p for this prime finite field.
 BigInteger

          Returns the prime p of this prime finite field.
 int

          Returns a hash code value for this prime finite field.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

ECFieldFp

public ECFieldFp(BigInteger p)
Creates an elliptic curve prime finite field with the specified prime p.

Parameters:
p - the prime.
Method Detail

equals

public boolean equals(Object obj)
Compares this prime finite field for equality with the specified object.

Overrides:
equals in class Object
Parameters:
obj - the object to be compared.
Returns:
true if obj is an instance of ECFieldFp and the prime value match, false otherwise.

getFieldSize

public int getFieldSize()
Returns the field size in bits which is size of prime p for this prime finite field.

Returns:
the field size in bits.

getP

public BigInteger getP()
Returns the prime p of this prime finite field.

Returns:
the prime.

hashCode

public int hashCode()
Returns a hash code value for this prime finite field.

Overrides:
hashCode in class Object
Returns:
a hash code value.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.