This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class ECGenParameterSpec

java.lang.Object extended by java.security.spec.ECGenParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class ECGenParameterSpec
extends Object
implements AlgorithmParameterSpec

This immutable class specifies the set of parameters used for generating elliptic curve (EC) domain parameters.


Constructor Summary

          Creates a parameter specification for EC parameter generation using a standard (or predefined) name stdName in order to generate the corresponding (precomputed) elliptic curve domain parameters.
 
Method Summary
 String

          Returns the standard or predefined name of the to-be-generated EC domain parameters.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

ECGenParameterSpec

public ECGenParameterSpec(String stdName)
Creates a parameter specification for EC parameter generation using a standard (or predefined) name stdName in order to generate the corresponding (precomputed) elliptic curve domain parameters. For the list of supported names, please consult the documentation of provider whose implementation will be used.

Parameters:
stdName - the standard name of the to-be-generated EC domain parameters.
Method Detail

getName

public String getName()
Returns the standard or predefined name of the to-be-generated EC domain parameters.

Returns:
the standard or predefined name.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.