This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class ECParameterSpec

java.lang.Object extended by java.security.spec.ECParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class ECParameterSpec
extends Object
implements AlgorithmParameterSpec

This immutable class specifies the set of domain parameters used with elliptic curve cryptography (ECC).


Constructor Summary

          Creates elliptic curve domain parameters based on the specified values.
 
Method Summary
 int

          Returns the cofactor.
 EllipticCurve

          Returns the elliptic curve that this parameter defines.
 ECPoint

          Returns the generator which is also known as the base point.
 BigInteger

          Returns the order of the generator.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

ECParameterSpec

public ECParameterSpec(EllipticCurve curve,
                       ECPoint g,
                       BigInteger n,
                       int h)
Creates elliptic curve domain parameters based on the specified values.

Parameters:
curve - the elliptic curve which this parameter defines.
g - the generator which is also known as the base point.
n - the order of the generator g.
h - the cofactor.
Method Detail

getCofactor

public int getCofactor()
Returns the cofactor.

Returns:
the cofactor.

getCurve

public EllipticCurve getCurve()
Returns the elliptic curve that this parameter defines.

Returns:
the elliptic curve that this parameter defines.

getGenerator

public ECPoint getGenerator()
Returns the generator which is also known as the base point.

Returns:
the generator which is also known as the base point.

getOrder

public BigInteger getOrder()
Returns the order of the generator.

Returns:
the order of the generator.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.