This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class ECPoint

java.lang.Object extended by java.security.spec.ECPoint

public class ECPoint
extends Object

This immutable class represents a point on an elliptic curve (EC) in affine coordinates. Other coordinate systems can extend this class to represent this point in other coordinates.


Field Summary
static ECPoint POINT_INFINITY
          This defines the point at infinity.
 
Constructor Summary

          Creates an ECPoint from the specified affine x-coordinate x and affine y-coordinate y.
 
Method Summary
 boolean

          Compares this elliptic curve point for equality with the specified object.
 BigInteger

          Returns the affine x-coordinate x.
 BigInteger

          Returns the affine y-coordinate y.
 int

          Returns a hash code value for this elliptic curve point.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Field Detail

POINT_INFINITY

public static final ECPoint POINT_INFINITY
This defines the point at infinity.
Constructor Detail

ECPoint

public ECPoint(BigInteger x,
               BigInteger y)
Creates an ECPoint from the specified affine x-coordinate x and affine y-coordinate y.

Parameters:
x - the affine x-coordinate.
y - the affine y-coordinate.
Method Detail

equals

public boolean equals(Object obj)
Compares this elliptic curve point for equality with the specified object.

Overrides:
equals in class Object
Parameters:
obj - the object to be compared.
Returns:
true if obj is an instance of ECPoint and the affine coordinates match, false otherwise.

getAffineX

public BigInteger getAffineX()
Returns the affine x-coordinate x. Note: POINT_INFINITY has a null affine x-coordinate.

Returns:
the affine x-coordinate.

getAffineY

public BigInteger getAffineY()
Returns the affine y-coordinate y. Note: POINT_INFINITY has a null affine y-coordinate.

Returns:
the affine y-coordinate.

hashCode

public int hashCode()
Returns a hash code value for this elliptic curve point.

Overrides:
hashCode in class Object
Returns:
a hash code value.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.