This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class ECPrivateKeySpec

java.lang.Object extended by java.security.spec.ECPrivateKeySpec
All Implemented Interfaces:
KeySpec

public class ECPrivateKeySpec
extends Object
implements KeySpec

This immutable class specifies an elliptic curve private key with its associated parameters.


Constructor Summary

          Creates a new ECPrivateKeySpec with the specified parameter values.
 
Method Summary
 ECParameterSpec

          Returns the associated elliptic curve domain parameters.
 BigInteger

          Returns the private value S.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

ECPrivateKeySpec

public ECPrivateKeySpec(BigInteger s,
                        ECParameterSpec params)
Creates a new ECPrivateKeySpec with the specified parameter values.

Parameters:
s - the private value.
params - the associated elliptic curve domain parameters.
Method Detail

getParams

public ECParameterSpec getParams()
Returns the associated elliptic curve domain parameters.

Returns:
the EC domain parameters.

getS

public BigInteger getS()
Returns the private value S.

Returns:
the private value S.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.