This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class EllipticCurve

java.lang.Object extended by java.security.spec.EllipticCurve

public class EllipticCurve
extends Object

This immutable class holds the necessary values needed to represent an elliptic curve.


Constructor Summary

          Creates an elliptic curve with the specified elliptic field field and the coefficients a and b.
EllipticCurve(ECField field, BigInteger a, BigInteger b, byte[] seed)

          Creates an elliptic curve with the specified elliptic field field, the coefficients a and b, and the seed used for curve generation.
 
Method Summary
 boolean

          Compares this elliptic curve for equality with the specified object.
 BigInteger

          Returns the first coefficient a of the elliptic curve.
 BigInteger

          Returns the second coefficient b of the elliptic curve.
 ECField

          Returns the finite field field that this elliptic curve is over.
 byte[]

          Returns the seeding bytes seed used during curve generation.
 int

          Returns a hash code value for this elliptic curve.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

EllipticCurve

public EllipticCurve(ECField field,
                     BigInteger a,
                     BigInteger b)
Creates an elliptic curve with the specified elliptic field field and the coefficients a and b.

Parameters:
field - the finite field that this elliptic curve is over.
a - the first coefficient of this elliptic curve.
b - the second coefficient of this elliptic curve.

EllipticCurve

public EllipticCurve(ECField field,
                     BigInteger a,
                     BigInteger b,
                     byte[] seed)
Creates an elliptic curve with the specified elliptic field field, the coefficients a and b, and the seed used for curve generation.

Parameters:
field - the finite field that this elliptic curve is over.
a - the first coefficient of this elliptic curve.
b - the second coefficient of this elliptic curve.
seed - the bytes used during curve generation for later validation. Contents of this array are copied to protect against subsequent modification.
Method Detail

equals

public boolean equals(Object obj)
Compares this elliptic curve for equality with the specified object.

Overrides:
equals in class Object
Parameters:
obj - the object to be compared.
Returns:
true if obj is an instance of EllipticCurve and the field, A, B, and seeding bytes match, false otherwise.

getA

public BigInteger getA()
Returns the first coefficient a of the elliptic curve.

Returns:
the first coefficient a.

getB

public BigInteger getB()
Returns the second coefficient b of the elliptic curve.

Returns:
the second coefficient b.

getField

public ECField getField()
Returns the finite field field that this elliptic curve is over.

Returns:
the field field that this curve is over.

getSeed

public byte[] getSeed()
Returns the seeding bytes seed used during curve generation. May be null if not specified.

Returns:
the seeding bytes seed. A new array is returned each time this method is called.

hashCode

public int hashCode()
Returns a hash code value for this elliptic curve.

Overrides:
hashCode in class Object
Returns:
a hash code value.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.