This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class EncodedKeySpec

java.lang.Object extended by java.security.spec.EncodedKeySpec
All Implemented Interfaces:
KeySpec
Direct Known Subclasses:
PKCS8EncodedKeySpec, X509EncodedKeySpec

public abstract class EncodedKeySpec
extends Object
implements KeySpec

This class represents a public or private key in encoded format.


Constructor Summary
EncodedKeySpec(byte[] encodedKey)

          Creates a new EncodedKeySpec with the given encoded key.
 
Method Summary
 byte[]

          Returns the encoded key.
abstract String

          Returns the name of the encoding format associated with this key specification.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

EncodedKeySpec

public EncodedKeySpec(byte[] encodedKey)
Creates a new EncodedKeySpec with the given encoded key.

Parameters:
encodedKey - the encoded key. The contents of the array are copied to protect against subsequent modification.
Method Detail

getEncoded

public byte[] getEncoded()
Returns the encoded key.

Returns:
the encoded key. Returns a new array each time this method is called.

getFormat

public abstract String getFormat()
Returns the name of the encoding format associated with this key specification.

If the opaque representation of a key (see {@link java.security.Key Key}) can be transformed (see {@link java.security.KeyFactory KeyFactory}) into this key specification (or a subclass of it), getFormat called on the opaque key returns the same value as the getFormat method of this key specification.

Returns:
a string representation of the encoding format.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.