This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
exception InvalidKeySpecException

java.lang.Object extended by java.lang.Throwable extended by java.lang.Exception extended by java.security.GeneralSecurityException extended by java.security.spec.InvalidKeySpecException
All Implemented Interfaces:
Serializable

public exception InvalidKeySpecException
extends GeneralSecurityException

This is the exception for invalid key specifications.


Constructor Summary

          Constructs an InvalidKeySpecException with no detail message.

          Constructs an InvalidKeySpecException with the specified detail message.

          Creates a InvalidKeySpecException with the specified detail message and cause.

          Creates a InvalidKeySpecException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
 
Method Summary
 
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

InvalidKeySpecException

public InvalidKeySpecException()
Constructs an InvalidKeySpecException with no detail message. A detail message is a String that describes this particular exception.


InvalidKeySpecException

public InvalidKeySpecException(String msg)
Constructs an InvalidKeySpecException with the specified detail message. A detail message is a String that describes this particular exception.

Parameters:
msg - the detail message.

InvalidKeySpecException

public InvalidKeySpecException(String message,
                               Throwable cause)
Creates a InvalidKeySpecException with the specified detail message and cause.

Parameters:
message - the detail message (which is saved for later retrieval by the {@link #getMessage()} method).
cause - the cause (which is saved for later retrieval by the {@link #getCause()} method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

InvalidKeySpecException

public InvalidKeySpecException(Throwable cause)
Creates a InvalidKeySpecException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

Parameters:
cause - the cause (which is saved for later retrieval by the {@link #getCause()} method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.