This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class MGF1ParameterSpec

java.lang.Object extended by java.security.spec.MGF1ParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class MGF1ParameterSpec
extends Object
implements AlgorithmParameterSpec

This class specifies the set of parameters used with mask generation function MGF1 in OAEP Padding and RSA-PSS signature scheme, as defined in the PKCS #1 v2.1 standard.

Its ASN.1 definition in PKCS#1 standard is described below:

 MGF1Parameters ::= OAEP-PSSDigestAlgorthms
 
where
 OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-sha1 PARAMETERS NULL   }|
   { OID id-sha256 PARAMETERS NULL }|
   { OID id-sha384 PARAMETERS NULL }|
   { OID id-sha512 PARAMETERS NULL },
   ...  -- Allows for future expansion --
 }
 


Field Summary
static MGF1ParameterSpec SHA1
          The MGF1ParameterSpec which uses "SHA-1" message digest.
static MGF1ParameterSpec SHA256
          The MGF1ParameterSpec which uses "SHA-256" message digest.
static MGF1ParameterSpec SHA384
          The MGF1ParameterSpec which uses "SHA-384" message digest.
static MGF1ParameterSpec SHA512
          The MGF1ParameterSpec which uses SHA-512 message digest.
 
Constructor Summary

          Constructs a parameter set for mask generation function MGF1 as defined in the PKCS #1 standard.
 
Method Summary
 String

          Returns the algorithm name of the message digest used by the mask generation function.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Field Detail

SHA1

public static final MGF1ParameterSpec SHA1
The MGF1ParameterSpec which uses "SHA-1" message digest.

SHA256

public static final MGF1ParameterSpec SHA256
The MGF1ParameterSpec which uses "SHA-256" message digest.

SHA384

public static final MGF1ParameterSpec SHA384
The MGF1ParameterSpec which uses "SHA-384" message digest.

SHA512

public static final MGF1ParameterSpec SHA512
The MGF1ParameterSpec which uses SHA-512 message digest.
Constructor Detail

MGF1ParameterSpec

public MGF1ParameterSpec(String mdName)
Constructs a parameter set for mask generation function MGF1 as defined in the PKCS #1 standard.

Parameters:
mdName - the algorithm name for the message digest used in this mask generation function MGF1.
Method Detail

getDigestAlgorithm

public String getDigestAlgorithm()
Returns the algorithm name of the message digest used by the mask generation function.

Returns:
the algorithm name of the message digest.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.