This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class PKCS8EncodedKeySpec

java.lang.Object extended by java.security.spec.EncodedKeySpec extended by java.security.spec.PKCS8EncodedKeySpec
All Implemented Interfaces:
KeySpec

public class PKCS8EncodedKeySpec
extends EncodedKeySpec

This class represents the ASN.1 encoding of a private key, encoded according to the ASN.1 type PrivateKeyInfo. The PrivateKeyInfo syntax is defined in the PKCS#8 standard as follows:

 PrivateKeyInfo ::= SEQUENCE {
   version Version,
   privateKeyAlgorithm PrivateKeyAlgorithmIdentifier,
   privateKey PrivateKey,
   attributes [0] IMPLICIT Attributes OPTIONAL }

 Version ::= INTEGER

 PrivateKeyAlgorithmIdentifier ::= AlgorithmIdentifier

 PrivateKey ::= OCTET STRING

 Attributes ::= SET OF Attribute
 


Constructor Summary
PKCS8EncodedKeySpec(byte[] encodedKey)

          Creates a new PKCS8EncodedKeySpec with the given encoded key.
 
Method Summary
 byte[]

          Returns the key bytes, encoded according to the PKCS #8 standard.
 String

          Returns the name of the encoding format associated with this key specification.
 
Methods inherited from class java.security.spec.EncodedKeySpec
getEncoded, getFormat
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

PKCS8EncodedKeySpec

public PKCS8EncodedKeySpec(byte[] encodedKey)
Creates a new PKCS8EncodedKeySpec with the given encoded key.

Parameters:
encodedKey - the key, which is assumed to be encoded according to the PKCS #8 standard. The contents of the array are copied to protect against subsequent modification.
Method Detail

getEncoded

public byte[] getEncoded()
Returns the key bytes, encoded according to the PKCS #8 standard.

Overrides:
getEncoded in class EncodedKeySpec
Returns:
the PKCS #8 encoding of the key. Returns a new array each time this method is called.

getFormat

public final String getFormat()
Returns the name of the encoding format associated with this key specification.

Overrides:
getFormat in class EncodedKeySpec
Returns:
the string "PKCS#8".


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.