This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class PSSParameterSpec

java.lang.Object extended by java.security.spec.PSSParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class PSSParameterSpec
extends Object
implements AlgorithmParameterSpec

This class specifies a parameter spec for RSA-PSS signature scheme, as defined in the PKCS#1 v2.1 standard.

Its ASN.1 definition in PKCS#1 standard is described below:

 RSASSA-PSS-params ::= SEQUENCE {
   hashAlgorithm      [0] OAEP-PSSDigestAlgorithms  DEFAULT sha1,
   maskGenAlgorithm   [1] PKCS1MGFAlgorithms  DEFAULT mgf1SHA1,
   saltLength         [2] INTEGER  DEFAULT 20,
   trailerField       [3] INTEGER  DEFAULT 1
 }
 
where
 OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-sha1 PARAMETERS NULL   }|
   { OID id-sha256 PARAMETERS NULL }|
   { OID id-sha384 PARAMETERS NULL }|
   { OID id-sha512 PARAMETERS NULL },
   ...  -- Allows for future expansion --
 }

 PKCS1MGFAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-mgf1 PARAMETERS OAEP-PSSDigestAlgorithms },
   ...  -- Allows for future expansion --
 }
 

Note: the PSSParameterSpec.DEFAULT uses the following: message digest -- "SHA-1" mask generation function (mgf) -- "MGF1" parameters for mgf -- MGF1ParameterSpec.SHA1 SaltLength -- 20 TrailerField -- 1


Field Summary
static PSSParameterSpec DEFAULT
          The PSS parameter set with all default values.
 
Constructor Summary
PSSParameterSpec(int saltLen)

          Creates a new PSSParameterSpec using the specified salt length and other default values as defined in PKCS#1.
PSSParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)

          Creates a new PSSParameterSpec as defined in the PKCS #1 standard using the specified message digest, mask generation function, parameters for mask generation function, salt length, and trailer field values.
 
Method Summary
 String

          Returns the message digest algorithm name.
 String

          Returns the mask generation function algorithm name.
 AlgorithmParameterSpec

          Returns the parameters for the mask generation function.
 int

          Returns the salt length in bits.
 int

          Returns the value for the trailer field, i.e.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Field Detail

DEFAULT

public static final PSSParameterSpec DEFAULT
The PSS parameter set with all default values.
Constructor Detail

PSSParameterSpec

public PSSParameterSpec(int saltLen)
Creates a new PSSParameterSpec using the specified salt length and other default values as defined in PKCS#1.

Parameters:
saltLen - the length of salt in bits to be used in PKCS#1 PSS encoding.

PSSParameterSpec

public PSSParameterSpec(String mdName,
                        String mgfName,
                        AlgorithmParameterSpec mgfSpec,
                        int saltLen,
                        int trailerField)
Creates a new PSSParameterSpec as defined in the PKCS #1 standard using the specified message digest, mask generation function, parameters for mask generation function, salt length, and trailer field values.

Parameters:
mdName - the algorithm name of the hash function.
mgfName - the algorithm name of the mask generation function.
mgfSpec - the parameters for the mask generation function. If null is specified, null will be returned by getMGFParameters().
saltLen - the length of salt.
trailerField - the value of the trailer field.
Method Detail

getDigestAlgorithm

public String getDigestAlgorithm()
Returns the message digest algorithm name.

Returns:
the message digest algorithm name.

getMGFAlgorithm

public String getMGFAlgorithm()
Returns the mask generation function algorithm name.

Returns:
the mask generation function algorithm name.

getMGFParameters

public AlgorithmParameterSpec getMGFParameters()
Returns the parameters for the mask generation function.

Returns:
the parameters for the mask generation function.

getSaltLength

public int getSaltLength()
Returns the salt length in bits.

Returns:
the salt length.

getTrailerField

public int getTrailerField()
Returns the value for the trailer field, i.e. bc in PKCS#1 v2.1.

Returns:
the value for the trailer field, i.e. bc in PKCS#1 v2.1.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.