This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class RSAKeyGenParameterSpec

java.lang.Object extended by java.security.spec.RSAKeyGenParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class RSAKeyGenParameterSpec
extends Object
implements AlgorithmParameterSpec

This class specifies the set of parameters used to generate an RSA key pair.


Field Summary
static BigInteger F0
          The public-exponent value F0 = 3.
static BigInteger F4
          The public exponent-value F4 = 65537.
 
Constructor Summary
RSAKeyGenParameterSpec(int keysize, BigInteger publicExponent)

          Constructs a new RSAParameterSpec object from the given keysize and public-exponent value.
 
Method Summary
 int

          Returns the keysize.
 BigInteger

          Returns the public-exponent value.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Field Detail

F0

public static final BigInteger F0
The public-exponent value F0 = 3.

F4

public static final BigInteger F4
The public exponent-value F4 = 65537.
Constructor Detail

RSAKeyGenParameterSpec

public RSAKeyGenParameterSpec(int keysize,
                              BigInteger publicExponent)
Constructs a new RSAParameterSpec object from the given keysize and public-exponent value.

Parameters:
keysize - the modulus size (specified in number of bits)
publicExponent - the public exponent
Method Detail

getKeysize

public int getKeysize()
Returns the keysize.

Returns:
the keysize.

getPublicExponent

public BigInteger getPublicExponent()
Returns the public-exponent value.

Returns:
the public-exponent value.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.