This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class RSAMultiPrimePrivateCrtKeySpec

java.lang.Object extended by java.security.spec.RSAPrivateKeySpec extended by java.security.spec.RSAMultiPrimePrivateCrtKeySpec
All Implemented Interfaces:
KeySpec

public class RSAMultiPrimePrivateCrtKeySpec
extends RSAPrivateKeySpec

This class specifies an RSA multi-prime private key, as defined in the PKCS#1 v2.1, using the Chinese Remainder Theorem (CRT) information values for efficiency.


Constructor Summary
RSAMultiPrimePrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)

          Creates a new RSAMultiPrimePrivateCrtKeySpec given the modulus, publicExponent, privateExponent, primeP, primeQ, primeExponentP, primeExponentQ, crtCoefficient, and otherPrimeInfo as defined in PKCS#1 v2.1.
 
Method Summary
 BigInteger

          Returns the crtCoefficient.
 RSAOtherPrimeInfo[]

          Returns a copy of the otherPrimeInfo or null if there are only two prime factors (p and q).
 BigInteger

          Returns the primeExponentP.
 BigInteger

          Returns the primeExponentQ.
 BigInteger

          Returns the primeP.
 BigInteger

          Returns the primeQ.
 BigInteger

          Returns the public exponent.
 
Methods inherited from class java.security.spec.RSAPrivateKeySpec
getModulus, getPrivateExponent
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

RSAMultiPrimePrivateCrtKeySpec

public RSAMultiPrimePrivateCrtKeySpec(BigInteger modulus,
                                      BigInteger publicExponent,
                                      BigInteger privateExponent,
                                      BigInteger primeP,
                                      BigInteger primeQ,
                                      BigInteger primeExponentP,
                                      BigInteger primeExponentQ,
                                      BigInteger crtCoefficient,
                                      RSAOtherPrimeInfo[] otherPrimeInfo)
Creates a new RSAMultiPrimePrivateCrtKeySpec given the modulus, publicExponent, privateExponent, primeP, primeQ, primeExponentP, primeExponentQ, crtCoefficient, and otherPrimeInfo as defined in PKCS#1 v2.1.

Note that the contents of otherPrimeInfo are copied to protect against subsequent modification when constructing this object.

Parameters:
modulus - the modulus n.
publicExponent - the public exponent e.
privateExponent - the private exponent d.
primeP - the prime factor p of n.
primeQ - the prime factor q of n.
primeExponentP - this is d mod (p-1).
primeExponentQ - this is d mod (q-1).
crtCoefficient - the Chinese Remainder Theorem coefficient q-1 mod p.
otherPrimeInfo - triplets of the rest of primes, null can be specified if there are only two prime factors (p and q).
Method Detail

getCrtCoefficient

public BigInteger getCrtCoefficient()
Returns the crtCoefficient.

Returns:
the crtCoefficient.

getOtherPrimeInfo

public RSAOtherPrimeInfo[] getOtherPrimeInfo()
Returns a copy of the otherPrimeInfo or null if there are only two prime factors (p and q).

Returns:
the otherPrimeInfo. Returns a new array each time this method is called.

getPrimeExponentP

public BigInteger getPrimeExponentP()
Returns the primeExponentP.

Returns:
the primeExponentP.

getPrimeExponentQ

public BigInteger getPrimeExponentQ()
Returns the primeExponentQ.

Returns:
the primeExponentQ.

getPrimeP

public BigInteger getPrimeP()
Returns the primeP.

Returns:
the primeP.

getPrimeQ

public BigInteger getPrimeQ()
Returns the primeQ.

Returns:
the primeQ.

getPublicExponent

public BigInteger getPublicExponent()
Returns the public exponent.

Returns:
the public exponent.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.