This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class RSAOtherPrimeInfo

java.lang.Object extended by java.security.spec.RSAOtherPrimeInfo

public class RSAOtherPrimeInfo
extends Object

This class represents the triplet (prime, exponent, and coefficient) inside RSA's OtherPrimeInfo structure, as defined in the PKCS#1 v2.1. The ASN.1 syntax of RSA's OtherPrimeInfo is as follows:

 OtherPrimeInfo ::= SEQUENCE {
   prime INTEGER,
   exponent INTEGER,
   coefficient INTEGER
   }

 


Constructor Summary
RSAOtherPrimeInfo(BigInteger prime, BigInteger primeExponent, BigInteger crtCoefficient)

          Creates a new RSAOtherPrimeInfo given the prime, primeExponent, and crtCoefficient as defined in PKCS#1.
 
Method Summary
 BigInteger

          Returns the prime's crtCoefficient.
 BigInteger

          Returns the prime's exponent.
 BigInteger

          Returns the prime.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

RSAOtherPrimeInfo

public RSAOtherPrimeInfo(BigInteger prime,
                         BigInteger primeExponent,
                         BigInteger crtCoefficient)
Creates a new RSAOtherPrimeInfo given the prime, primeExponent, and crtCoefficient as defined in PKCS#1.

Parameters:
prime - the prime factor of n.
primeExponent - the exponent.
crtCoefficient - the Chinese Remainder Theorem coefficient.
Method Detail

getCrtCoefficient

public final BigInteger getCrtCoefficient()
Returns the prime's crtCoefficient.

Returns:
the crtCoefficient.

getExponent

public final BigInteger getExponent()
Returns the prime's exponent.

Returns:
the primeExponent.

getPrime

public final BigInteger getPrime()
Returns the prime.

Returns:
the prime.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.