This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class RSAPrivateKeySpec

java.lang.Object extended by java.security.spec.RSAPrivateKeySpec
All Implemented Interfaces:
KeySpec
Direct Known Subclasses:
RSAMultiPrimePrivateCrtKeySpec, RSAPrivateCrtKeySpec

public class RSAPrivateKeySpec
extends Object
implements KeySpec

This class specifies an RSA private key.


Constructor Summary
RSAPrivateKeySpec(BigInteger modulus, BigInteger privateExponent)

          Creates a new RSAPrivateKeySpec.
 
Method Summary
 BigInteger

          Returns the modulus.
 BigInteger

          Returns the private exponent.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

RSAPrivateKeySpec

public RSAPrivateKeySpec(BigInteger modulus,
                         BigInteger privateExponent)
Creates a new RSAPrivateKeySpec.

Parameters:
modulus - the modulus
privateExponent - the private exponent
Method Detail

getModulus

public BigInteger getModulus()
Returns the modulus.

Returns:
the modulus

getPrivateExponent

public BigInteger getPrivateExponent()
Returns the private exponent.

Returns:
the private exponent


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.