This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


java.security.spec
class RSAPublicKeySpec

java.lang.Object extended by java.security.spec.RSAPublicKeySpec
All Implemented Interfaces:
KeySpec

Most common way to construct:

BigInteger modBI = …;
BigInteger expBI = …;

RSAPublicKeySpec ks = new RSAPublicKeySpec(modBI, expBI);

Based on 21 examples


public class RSAPublicKeySpec
extends Object
implements KeySpec

This class specifies an RSA public key.


Constructor Summary
RSAPublicKeySpec(BigInteger modulus, BigInteger publicExponent)

          Creates a new RSAPublicKeySpec.
 
Method Summary
 BigInteger

          Returns the modulus.
 BigInteger

          Returns the public exponent.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

RSAPublicKeySpec

public RSAPublicKeySpec(BigInteger modulus,
                        BigInteger publicExponent)
Creates a new RSAPublicKeySpec.

Parameters:
modulus - the modulus
publicExponent - the public exponent
Method Detail

getModulus

public BigInteger getModulus()
Returns the modulus.

Returns:
the modulus

getPublicExponent

public BigInteger getPublicExponent()
Returns the public exponent.

Returns:
the public exponent


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.