This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class DESKeySpec

java.lang.Object extended by javax.crypto.spec.DESKeySpec
All Implemented Interfaces:
KeySpec

public class DESKeySpec
extends Object
implements KeySpec

This class specifies a DES key.


Field Summary
static int DES_KEY_LEN
          The constant which defines the length of a DES key in bytes.
 
Constructor Summary
DESKeySpec(byte[] key)

          Creates a DESKeySpec object using the first 8 bytes in key as the key material for the DES key.
DESKeySpec(byte[] key, int offset)

          Creates a DESKeySpec object using the first 8 bytes in key, beginning at offset inclusive, as the key material for the DES key.
 
Method Summary
 byte[]

          Returns the DES key material.
static boolean
isParityAdjusted(byte[] key, int offset)

          Checks if the given DES key material, starting at offset inclusive, is parity-adjusted.
static boolean
isWeak(byte[] key, int offset)

          Checks if the given DES key material is weak or semi-weak.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Field Detail

DES_KEY_LEN

public static final int DES_KEY_LEN
The constant which defines the length of a DES key in bytes.
Constructor Detail

DESKeySpec

public DESKeySpec(byte[] key)
           throws InvalidKeyException
Creates a DESKeySpec object using the first 8 bytes in key as the key material for the DES key.

The bytes that constitute the DES key are those between key[0] and key[7] inclusive.

Parameters:
key - the buffer with the DES key material. The first 8 bytes of the buffer are copied to protect against subsequent modification.
Throws:
InvalidKeyException - if the given key material is shorter than 8 bytes.

DESKeySpec

public DESKeySpec(byte[] key,
                  int offset)
           throws InvalidKeyException
Creates a DESKeySpec object using the first 8 bytes in key, beginning at offset inclusive, as the key material for the DES key.

The bytes that constitute the DES key are those between key[offset] and key[offset+7] inclusive.

Parameters:
key - the buffer with the DES key material. The first 8 bytes of the buffer beginning at offset inclusive are copied to protect against subsequent modification.
offset - the offset in key, where the DES key material starts.
Throws:
InvalidKeyException - if the given key material, starting at offset inclusive, is shorter than 8 bytes.
Method Detail

getKey

public byte[] getKey()
Returns the DES key material.

Returns:
the DES key material. Returns a new array each time this method is called.

isParityAdjusted

public static boolean isParityAdjusted(byte[] key,
                                       int offset)
                                throws InvalidKeyException
Checks if the given DES key material, starting at offset inclusive, is parity-adjusted.

Parameters:
key - the buffer with the DES key material.
offset - the offset in key, where the DES key material starts.
Returns:
true if the given DES key material is parity-adjusted, false otherwise.
Throws:
InvalidKeyException - if the given key material is null, or starting at offset inclusive, is shorter than 8 bytes.

isWeak

public static boolean isWeak(byte[] key,
                             int offset)
                      throws InvalidKeyException
Checks if the given DES key material is weak or semi-weak.

Parameters:
key - the buffer with the DES key material.
offset - the offset in key, where the DES key material starts.
Returns:
true if the given DES key material is weak or semi-weak, false otherwise.
Throws:
InvalidKeyException - if the given key material is null, or starting at offset inclusive, is shorter than 8 bytes.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.