This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class DHGenParameterSpec

java.lang.Object extended by javax.crypto.spec.DHGenParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class DHGenParameterSpec
extends Object
implements AlgorithmParameterSpec

This class specifies the set of parameters used for generating Diffie-Hellman (system) parameters for use in Diffie-Hellman key agreement. This is typically done by a central authority.

The central authority, after computing the parameters, must send this information to the parties looking to agree on a secret key.


Constructor Summary
DHGenParameterSpec(int primeSize, int exponentSize)

          Constructs a parameter set for the generation of Diffie-Hellman (system) parameters.
 
Method Summary
 int

          Returns the size in bits of the random exponent (private value).
 int

          Returns the size in bits of the prime modulus.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

DHGenParameterSpec

public DHGenParameterSpec(int primeSize,
                          int exponentSize)
Constructs a parameter set for the generation of Diffie-Hellman (system) parameters. The constructed parameter set can be used to initialize an {@link java.security.AlgorithmParameterGenerator AlgorithmParameterGenerator} object for the generation of Diffie-Hellman parameters.

Parameters:
primeSize - the size (in bits) of the prime modulus.
exponentSize - the size (in bits) of the random exponent.
Method Detail

getExponentSize

public int getExponentSize()
Returns the size in bits of the random exponent (private value).

Returns:
the size in bits of the random exponent (private value)

getPrimeSize

public int getPrimeSize()
Returns the size in bits of the prime modulus.

Returns:
the size in bits of the prime modulus


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.