This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class DHParameterSpec

java.lang.Object extended by javax.crypto.spec.DHParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class DHParameterSpec
extends Object
implements AlgorithmParameterSpec

This class specifies the set of parameters used with the Diffie-Hellman algorithm, as specified in PKCS #3: Diffie-Hellman Key-Agreement Standard.

A central authority generates parameters and gives them to the two entities seeking to generate a secret key. The parameters are a prime p, a base g, and optionally the length in bits of the private value, l.

It is possible that more than one instance of parameters may be generated by a given central authority, and that there may be more than one central authority. Indeed, each individual may be its own central authority, with different entities having different parameters.

Note that this class does not perform any validation on specified parameters. Thus, the specified values are returned directly even if they are null.


Constructor Summary

          Constructs a parameter set for Diffie-Hellman, using a prime modulus p and a base generator g.

          Constructs a parameter set for Diffie-Hellman, using a prime modulus p, a base generator g, and the size in bits, l, of the random exponent (private value).
 
Method Summary
 BigInteger

          Returns the base generator g.
 int

          Returns the size in bits, l, of the random exponent (private value).
 BigInteger

          Returns the prime modulus p.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

DHParameterSpec

public DHParameterSpec(BigInteger p,
                       BigInteger g)
Constructs a parameter set for Diffie-Hellman, using a prime modulus p and a base generator g.

Parameters:
p - the prime modulus
g - the base generator

DHParameterSpec

public DHParameterSpec(BigInteger p,
                       BigInteger g,
                       int l)
Constructs a parameter set for Diffie-Hellman, using a prime modulus p, a base generator g, and the size in bits, l, of the random exponent (private value).

Parameters:
p - the prime modulus
g - the base generator
l - the size in bits of the random exponent (private value)
Method Detail

getG

public BigInteger getG()
Returns the base generator g.

Returns:
the base generator g

getL

public int getL()
Returns the size in bits, l, of the random exponent (private value).

Returns:
the size in bits, l, of the random exponent (private value), or 0 if this size has not been set

getP

public BigInteger getP()
Returns the prime modulus p.

Returns:
the prime modulus p


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.