This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class DHPrivateKeySpec

java.lang.Object extended by javax.crypto.spec.DHPrivateKeySpec
All Implemented Interfaces:
KeySpec

public class DHPrivateKeySpec
extends Object
implements KeySpec

This class specifies a Diffie-Hellman private key with its associated parameters.

Note that this class does not perform any validation on specified parameters. Thus, the specified values are returned directly even if they are null.


Constructor Summary

          Constructor that takes a private value x, a prime modulus p, and a base generator g.
 
Method Summary
 BigInteger

          Returns the base generator g.
 BigInteger

          Returns the prime modulus p.
 BigInteger

          Returns the private value x.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

DHPrivateKeySpec

public DHPrivateKeySpec(BigInteger x,
                        BigInteger p,
                        BigInteger g)
Constructor that takes a private value x, a prime modulus p, and a base generator g.

Parameters:
x - private value x
p - prime modulus p
g - base generator g
Method Detail

getG

public BigInteger getG()
Returns the base generator g.

Returns:
the base generator g

getP

public BigInteger getP()
Returns the prime modulus p.

Returns:
the prime modulus p

getX

public BigInteger getX()
Returns the private value x.

Returns:
the private value x


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.