This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class DHPublicKeySpec

java.lang.Object extended by javax.crypto.spec.DHPublicKeySpec
All Implemented Interfaces:
KeySpec

public class DHPublicKeySpec
extends Object
implements KeySpec

This class specifies a Diffie-Hellman public key with its associated parameters.

Note that this class does not perform any validation on specified parameters. Thus, the specified values are returned directly even if they are null.


Constructor Summary

          Constructor that takes a public value y, a prime modulus p, and a base generator g.
 
Method Summary
 BigInteger

          Returns the base generator g.
 BigInteger

          Returns the prime modulus p.
 BigInteger

          Returns the public value y.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

DHPublicKeySpec

public DHPublicKeySpec(BigInteger y,
                       BigInteger p,
                       BigInteger g)
Constructor that takes a public value y, a prime modulus p, and a base generator g.

Parameters:
y - public value y
p - prime modulus p
g - base generator g
Method Detail

getG

public BigInteger getG()
Returns the base generator g.

Returns:
the base generator g

getP

public BigInteger getP()
Returns the prime modulus p.

Returns:
the prime modulus p

getY

public BigInteger getY()
Returns the public value y.

Returns:
the public value y


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.