This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class IvParameterSpec

java.lang.Object extended by javax.crypto.spec.IvParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class IvParameterSpec
extends Object
implements AlgorithmParameterSpec

This class specifies an initialization vector (IV). Examples which use IVs are ciphers in feedback mode, e.g., DES in CBC mode and RSA ciphers with OAEP encoding operation.


Constructor Summary
IvParameterSpec(byte[] iv)

          Creates an IvParameterSpec object using the bytes in iv as the IV.
IvParameterSpec(byte[] iv, int offset, int len)

          Creates an IvParameterSpec object using the first len bytes in iv, beginning at offset inclusive, as the IV.
 
Method Summary
 byte[]

          Returns the initialization vector (IV).
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

IvParameterSpec

public IvParameterSpec(byte[] iv)
Creates an IvParameterSpec object using the bytes in iv as the IV.

Parameters:
iv - the buffer with the IV. The contents of the buffer are copied to protect against subsequent modification.

IvParameterSpec

public IvParameterSpec(byte[] iv,
                       int offset,
                       int len)
Creates an IvParameterSpec object using the first len bytes in iv, beginning at offset inclusive, as the IV.

The bytes that constitute the IV are those between iv[offset] and iv[offset+len-1] inclusive.

Parameters:
iv - the buffer with the IV. The first len bytes of the buffer beginning at offset inclusive are copied to protect against subsequent modification.
offset - the offset in iv where the IV starts.
len - the number of IV bytes.
Method Detail

getIV

public byte[] getIV()
Returns the initialization vector (IV).

Returns:
the initialization vector (IV). Returns a new array each time this method is called.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.