This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class PSource.PSpecified

java.lang.Object extended by javax.crypto.spec.PSource extended by javax.crypto.spec.PSource.PSpecified
Enclosing class:
PSource

public static final class PSource.PSpecified
extends PSource

This class is used to explicitly specify the value for encoding input P in OAEP Padding.


Nested Class Summary
 
Nested classes/interfaces inherited from class javax.crypto.spec.PSource
PSource.PSpecified
   
Field Summary
static PSource.PSpecified DEFAULT
          The encoding input P whose value equals byte[0].
 
Constructor Summary

          Constructs the source explicitly with the specified value p as the encoding input P.
 
Method Summary
 byte[]

          Returns the value of encoding input P.
 
Methods inherited from class javax.crypto.spec.PSource
getAlgorithm
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Field Detail

DEFAULT

public static final PSource.PSpecified DEFAULT
The encoding input P whose value equals byte[0].
Constructor Detail

PSource.PSpecified

public PSource.PSpecified(byte[] p)
Constructs the source explicitly with the specified value p as the encoding input P. Note:

Parameters:
p - the value of the encoding input. The contents of the array are copied to protect against subsequent modification.
Method Detail

getValue

public byte[] getValue()
Returns the value of encoding input P.

Returns:
the value of encoding input P. A new array is returned each time this method is called.


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.