This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class RC2ParameterSpec

java.lang.Object extended by javax.crypto.spec.RC2ParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class RC2ParameterSpec
extends Object
implements AlgorithmParameterSpec

This class specifies the parameters used with the RC2 algorithm.

The parameters consist of an effective key size and optionally an 8-byte initialization vector (IV) (only in feedback mode).

This class can be used to initialize a Cipher object that implements the RC2 algorithm.


Constructor Summary
RC2ParameterSpec(int effectiveKeyBits)

          Constructs a parameter set for RC2 from the given effective key size (in bits).
RC2ParameterSpec(int effectiveKeyBits, byte[] iv)

          Constructs a parameter set for RC2 from the given effective key size (in bits) and an 8-byte IV.
RC2ParameterSpec(int effectiveKeyBits, byte[] iv, int offset)

          Constructs a parameter set for RC2 from the given effective key size (in bits) and IV.
 
Method Summary
 boolean

          Tests for equality between the specified object and this object.
 int

          Returns the effective key size in bits.
 byte[]

          Returns the IV or null if this parameter set does not contain an IV.
 int

          Calculates a hash code value for the object.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

RC2ParameterSpec

public RC2ParameterSpec(int effectiveKeyBits)
Constructs a parameter set for RC2 from the given effective key size (in bits).

Parameters:
effectiveKeyBits - the effective key size in bits.

RC2ParameterSpec

public RC2ParameterSpec(int effectiveKeyBits,
                        byte[] iv)
Constructs a parameter set for RC2 from the given effective key size (in bits) and an 8-byte IV.

The bytes that constitute the IV are those between iv[0] and iv[7] inclusive.

Parameters:
effectiveKeyBits - the effective key size in bits.
iv - the buffer with the 8-byte IV. The first 8 bytes of the buffer are copied to protect against subsequent modification.

RC2ParameterSpec

public RC2ParameterSpec(int effectiveKeyBits,
                        byte[] iv,
                        int offset)
Constructs a parameter set for RC2 from the given effective key size (in bits) and IV.

The IV is taken from iv, starting at offset inclusive. The bytes that constitute the IV are those between iv[offset] and iv[offset+7] inclusive.

Parameters:
effectiveKeyBits - the effective key size in bits.
iv - the buffer with the IV. The first 8 bytes of the buffer beginning at offset inclusive are copied to protect against subsequent modification.
offset - the offset in iv where the 8-byte IV starts.
Method Detail

equals

public boolean equals(Object obj)
Tests for equality between the specified object and this object. Two RC2ParameterSpec objects are considered equal if their effective key sizes and IVs are equal. (Two IV references are considered equal if both are null.)

Overrides:
equals in class Object
Parameters:
obj - the object to test for equality with this object.
Returns:
true if the objects are considered equal, false if obj is null or otherwise.

getEffectiveKeyBits

public int getEffectiveKeyBits()
Returns the effective key size in bits.

Returns:
the effective key size in bits.

getIV

public byte[] getIV()
Returns the IV or null if this parameter set does not contain an IV.

Returns:
the IV or null if this parameter set does not contain an IV. Returns a new array each time this method is called.

hashCode

public int hashCode()
Calculates a hash code value for the object. Objects that are equal will also have the same hashcode.

Overrides:
hashCode in class Object


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.