This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class RC5ParameterSpec

java.lang.Object extended by javax.crypto.spec.RC5ParameterSpec
All Implemented Interfaces:
AlgorithmParameterSpec

public class RC5ParameterSpec
extends Object
implements AlgorithmParameterSpec

This class specifies the parameters used with the RC5 algorithm.

The parameters consist of a version number, a rounds count, a word size, and optionally an initialization vector (IV) (only in feedback mode).

This class can be used to initialize a Cipher object that implements the RC5 algorithm as supplied by RSA Security Inc., or any parties authorized by RSA Security.


Constructor Summary
RC5ParameterSpec(int version, int rounds, int wordSize)

          Constructs a parameter set for RC5 from the given version, number of rounds and word size (in bits).
RC5ParameterSpec(int version, int rounds, int wordSize, byte[] iv)

          Constructs a parameter set for RC5 from the given version, number of rounds, word size (in bits), and IV.
RC5ParameterSpec(int version, int rounds, int wordSize, byte[] iv, int offset)

          Constructs a parameter set for RC5 from the given version, number of rounds, word size (in bits), and IV.
 
Method Summary
 boolean

          Tests for equality between the specified object and this object.
 byte[]

          Returns the IV or null if this parameter set does not contain an IV.
 int

          Returns the number of rounds.
 int

          Returns the version.
 int

          Returns the word size in bits.
 int

          Calculates a hash code value for the object.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

RC5ParameterSpec

public RC5ParameterSpec(int version,
                        int rounds,
                        int wordSize)
Constructs a parameter set for RC5 from the given version, number of rounds and word size (in bits).

Parameters:
version - the version.
rounds - the number of rounds.
wordSize - the word size in bits.

RC5ParameterSpec

public RC5ParameterSpec(int version,
                        int rounds,
                        int wordSize,
                        byte[] iv)
Constructs a parameter set for RC5 from the given version, number of rounds, word size (in bits), and IV.

Note that the size of the IV (block size) must be twice the word size. The bytes that constitute the IV are those between iv[0] and iv[2*(wordSize/8)-1] inclusive.

Parameters:
version - the version.
rounds - the number of rounds.
wordSize - the word size in bits.
iv - the buffer with the IV. The first 2*(wordSize/8) bytes of the buffer are copied to protect against subsequent modification.

RC5ParameterSpec

public RC5ParameterSpec(int version,
                        int rounds,
                        int wordSize,
                        byte[] iv,
                        int offset)
Constructs a parameter set for RC5 from the given version, number of rounds, word size (in bits), and IV.

The IV is taken from iv, starting at offset inclusive. Note that the size of the IV (block size), starting at offset inclusive, must be twice the word size. The bytes that constitute the IV are those between iv[offset] and iv[offset+2*(wordSize/8)-1] inclusive.

Parameters:
version - the version.
rounds - the number of rounds.
wordSize - the word size in bits.
iv - the buffer with the IV. The first 2*(wordSize/8) bytes of the buffer beginning at offset inclusive are copied to protect against subsequent modification.
offset - the offset in iv where the IV starts.
Method Detail

equals

public boolean equals(Object obj)
Tests for equality between the specified object and this object. Two RC5ParameterSpec objects are considered equal if their version numbers, number of rounds, word sizes, and IVs are equal. (Two IV references are considered equal if both are null.)

Overrides:
equals in class Object
Parameters:
obj - the object to test for equality with this object.
Returns:
true if the objects are considered equal, false if obj is null or otherwise.

getIV

public byte[] getIV()
Returns the IV or null if this parameter set does not contain an IV.

Returns:
the IV or null if this parameter set does not contain an IV. Returns a new array each time this method is called.

getRounds

public int getRounds()
Returns the number of rounds.

Returns:
the number of rounds.

getVersion

public int getVersion()
Returns the version.

Returns:
the version.

getWordSize

public int getWordSize()
Returns the word size in bits.

Returns:
the word size in bits.

hashCode

public int hashCode()
Calculates a hash code value for the object. Objects that are equal will also have the same hashcode.

Overrides:
hashCode in class Object


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.