This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.crypto.spec
class SecretKeySpec

java.lang.Object extended by javax.crypto.spec.SecretKeySpec
All Implemented Interfaces:
KeySpec, SecretKey

public class SecretKeySpec
extends Object
implements KeySpec, SecretKey

This class specifies a secret key in a provider-independent fashion.

It can be used to construct a SecretKey from a byte array, without having to go through a (provider-based) SecretKeyFactory.

This class is only useful for raw secret keys that can be represented as a byte array and have no key parameters associated with them, e.g., DES or Triple DES keys.


Constructor Summary
SecretKeySpec(byte[] key, int offset, int len, String algorithm)

          Constructs a secret key from the given byte array, using the first len bytes of key, starting at offset inclusive.
SecretKeySpec(byte[] key, String algorithm)

          Constructs a secret key from the given byte array.
 
Method Summary
 boolean

          Tests for equality between the specified object and this object.
 String

          Returns the name of the algorithm associated with this secret key.
 byte[]

          Returns the key material of this secret key.
 String

          Returns the name of the encoding format for this secret key.
 int

          Calculates a hash code value for the object.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

SecretKeySpec

public SecretKeySpec(byte[] key,
                     int offset,
                     int len,
                     String algorithm)
Constructs a secret key from the given byte array, using the first len bytes of key, starting at offset inclusive.

The bytes that constitute the secret key are those between key[offset] and key[offset+len-1] inclusive.

This constructor does not check if the given bytes indeed specify a secret key of the specified algorithm. For example, if the algorithm is DES, this constructor does not check if key is 8 bytes long, and also does not check for weak or semi-weak keys. In order for those checks to be performed, an algorithm-specific key specification class (in this case: {@link DESKeySpec DESKeySpec}) must be used.

Parameters:
key - the key material of the secret key. The first len bytes of the array beginning at offset inclusive are copied to protect against subsequent modification.
offset - the offset in key where the key material starts.
len - the length of the key material.
algorithm - the name of the secret-key algorithm to be associated with the given key material. See Appendix A in the Java Cryptography Extension Reference Guide for information about standard algorithm names.

SecretKeySpec

public SecretKeySpec(byte[] key,
                     String algorithm)
Constructs a secret key from the given byte array.

This constructor does not check if the given bytes indeed specify a secret key of the specified algorithm. For example, if the algorithm is DES, this constructor does not check if key is 8 bytes long, and also does not check for weak or semi-weak keys. In order for those checks to be performed, an algorithm-specific key specification class (in this case: {@link DESKeySpec DESKeySpec}) should be used.

Parameters:
key - the key material of the secret key. The contents of the array are copied to protect against subsequent modification.
algorithm - the name of the secret-key algorithm to be associated with the given key material. See Appendix A in the Java Cryptography Extension Reference Guide for information about standard algorithm names.
Method Detail

equals

public boolean equals(Object obj)
Tests for equality between the specified object and this object. Two SecretKeySpec objects are considered equal if they are both SecretKey instances which have the same case-insensitive algorithm name and key encoding.

Overrides:
equals in class Object
Parameters:
obj - the object to test for equality with this object.
Returns:
true if the objects are considered equal, false if obj is null or otherwise.

getAlgorithm

public String getAlgorithm()
Returns the name of the algorithm associated with this secret key.

Returns:
the secret key algorithm.

getEncoded

public byte[] getEncoded()
Returns the key material of this secret key.

Returns:
the key material. Returns a new array each time this method is called.

getFormat

public String getFormat()
Returns the name of the encoding format for this secret key.

Returns:
the string "RAW".

hashCode

public int hashCode()
Calculates a hash code value for the object. Objects that are equal will also have the same hashcode.

Overrides:
hashCode in class Object


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.