This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.xml.crypto.dsig.spec
class ExcC14NParameterSpec

java.lang.Object extended by javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
All Implemented Interfaces:
C14NMethodParameterSpec

public final class ExcC14NParameterSpec
extends Object
implements C14NMethodParameterSpec

Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm. The parameters include an optional inclusive namespace prefix list. The XML Schema Definition of the Exclusive XML Canonicalization parameters is defined as:


 <schema xmlns="http://www.w3.org/2001/XMLSchema"
         xmlns:ec="http://www.w3.org/2001/10/xml-exc-c14n#"
         targetNamespace="http://www.w3.org/2001/10/xml-exc-c14n#"
         version="0.1" elementFormDefault="qualified">

 <element name="InclusiveNamespaces" type="ec:InclusiveNamespaces"/>
 <complexType name="InclusiveNamespaces">
   <attribute name="PrefixList" type="xsd:string"/>
 </complexType>
 </schema>
 


Field Summary
static String DEFAULT
          Indicates the default namespace ("#default").
 
Constructor Summary

          Creates a ExcC14NParameterSpec with an empty prefix list.

          Creates a ExcC14NParameterSpec with the specified list of prefixes.
 
Method Summary
 List

          Returns the inclusive namespace prefix list.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Field Detail

DEFAULT

public static final String DEFAULT
Indicates the default namespace ("#default").
Constructor Detail

ExcC14NParameterSpec

public ExcC14NParameterSpec()
Creates a ExcC14NParameterSpec with an empty prefix list.


ExcC14NParameterSpec

public ExcC14NParameterSpec(List prefixList)
Creates a ExcC14NParameterSpec with the specified list of prefixes. The list is copied to protect against subsequent modification.

Parameters:
prefixList - the inclusive namespace prefix list. Each entry in the list is a String that represents a namespace prefix.
Method Detail

getPrefixList

public List getPrefixList()
Returns the inclusive namespace prefix list. Each entry in the list is a String that represents a namespace prefix.

This implementation returns an {@link java.util.Collections#unmodifiableList unmodifiable list}.

Returns:
the inclusive namespace prefix list (may be empty but never null)


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.