This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.xml.crypto.dsig.spec
class HMACParameterSpec

java.lang.Object extended by javax.xml.crypto.dsig.spec.HMACParameterSpec
All Implemented Interfaces:
SignatureMethodParameterSpec

public final class HMACParameterSpec
extends Object
implements SignatureMethodParameterSpec

Parameters for the XML Signature HMAC Algorithm. The parameters include an optional output length which specifies the MAC truncation length in bits. The resulting HMAC will be truncated to the specified number of bits. If the parameter is not specified, then this implies that all the bits of the hash are to be output. The XML Schema Definition of the HMACOutputLength element is defined as:


 <element name="HMACOutputLength" minOccurs="0" type="ds:HMACOutputLengthType"/>
 <simpleType name="HMACOutputLengthType">
   <restriction base="integer"/>
 </simpleType>
 


Constructor Summary
HMACParameterSpec(int outputLength)

          Creates an HMACParameterSpec with the specified truncation length.
 
Method Summary
 int

          Returns the truncation length.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

HMACParameterSpec

public HMACParameterSpec(int outputLength)
Creates an HMACParameterSpec with the specified truncation length.

Parameters:
outputLength - the truncation length in number of bits
Method Detail

getOutputLength

public int getOutputLength()
Returns the truncation length.

Returns:
the truncation length in number of bits


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.