This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.xml.crypto.dsig.spec
class XPathFilter2ParameterSpec

java.lang.Object extended by javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
All Implemented Interfaces:
TransformParameterSpec

public final class XPathFilter2ParameterSpec
extends Object
implements TransformParameterSpec

Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm. The parameters include a list of one or more {@link XPathType} objects.


Constructor Summary

          Creates an XPathFilter2ParameterSpec.
 
Method Summary
 List

          Returns a list of one or more javax.xml.crypto.dsig.spec.XPathType objects.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

XPathFilter2ParameterSpec

public XPathFilter2ParameterSpec(List xPathList)
Creates an XPathFilter2ParameterSpec.

Parameters:
xPathList - a list of one or more {@link XPathType} objects. The list is defensively copied to protect against subsequent modification.
Method Detail

getXPathList

public List getXPathList()
Returns a list of one or more {@link XPathType} objects.

This implementation returns an {@link Collections#unmodifiableList unmodifiable list}.

Returns:
a List of XPathType objects (never null or empty)


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.