This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.xml.crypto.dsig.spec
class XPathFilterParameterSpec

java.lang.Object extended by javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
All Implemented Interfaces:
TransformParameterSpec

public final class XPathFilterParameterSpec
extends Object
implements TransformParameterSpec

Parameters for the XPath Filtering Transform Algorithm. The parameters include the XPath expression and an optional Map of additional namespace prefix mappings. The XML Schema Definition of the XPath Filtering transform parameters is defined as:


 <element name="XPath" type="string"/>
 


Constructor Summary

          Creates an XPathFilterParameterSpec with the specified XPath expression.
XPathFilterParameterSpec(String xPath, Map namespaceMap)

          Creates an XPathFilterParameterSpec with the specified XPath expression and namespace map.
 
Method Summary
 Map

          Returns a map of namespace prefixes.
 String

          Returns the XPath expression to be evaluated.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

XPathFilterParameterSpec

public XPathFilterParameterSpec(String xPath)
Creates an XPathFilterParameterSpec with the specified XPath expression.

Parameters:
xPath - the XPath expression to be evaluated

XPathFilterParameterSpec

public XPathFilterParameterSpec(String xPath,
                                Map namespaceMap)
Creates an XPathFilterParameterSpec with the specified XPath expression and namespace map. The map is copied to protect against subsequent modification.

Parameters:
xPath - the XPath expression to be evaluated
namespaceMap - the map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.
Method Detail

getNamespaceMap

public Map getNamespaceMap()
Returns a map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.

This implementation returns an {@link Collections#unmodifiableMap unmodifiable map}.

Returns:
a Map of namespace prefixes to namespace URIs (may be empty, but never null)

getXPath

public String getXPath()
Returns the XPath expression to be evaluated.

Returns:
the XPath expression to be evaluated


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.