This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.xml.crypto.dsig.spec
class XPathType

java.lang.Object extended by javax.xml.crypto.dsig.spec.XPathType

public class XPathType
extends Object

The XML Schema Definition of the XPath element as defined in the W3C Recommendation for XML-Signature XPath Filter 2.0:


 <schema xmlns="http://www.w3.org/2001/XMLSchema"
         xmlns:xf="http://www.w3.org/2002/06/xmldsig-filter2"
         targetNamespace="http://www.w3.org/2002/06/xmldsig-filter2"
         version="0.1" elementFormDefault="qualified">

 <element name="XPath"
          type="xf:XPathType"/>

 <complexType name="XPathType">
   <simpleContent>
     <extension base="string">
       <attribute name="Filter">
         <simpleType>
           <restriction base="string">
             <enumeration value="intersect"/>
             <enumeration value="subtract"/>
             <enumeration value="union"/>
           </restriction>
         </simpleType>
       </attribute>
     </extension>
   </simpleContent>
 </complexType>
 


Nested Class Summary
static class

           Represents the filter set operation.
 
Constructor Summary
XPathType(String expression, XPathType.Filter filter)

          Creates an XPathType instance with the specified XPath expression and filter.
XPathType(String expression, XPathType.Filter filter, Map namespaceMap)

          Creates an XPathType instance with the specified XPath expression, filter, and namespace map.
 
Method Summary
 String

          Returns the XPath expression to be evaluated.
 XPathType.Filter

          Returns the filter operation.
 Map

          Returns a map of namespace prefixes.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

XPathType

public XPathType(String expression,
                 XPathType.Filter filter)
Creates an XPathType instance with the specified XPath expression and filter.

Parameters:
expression - the XPath expression to be evaluated
filter - the filter operation ({@link Filter#INTERSECT}, {@link Filter#SUBTRACT}, or {@link Filter#UNION})

XPathType

public XPathType(String expression,
                 XPathType.Filter filter,
                 Map namespaceMap)
Creates an XPathType instance with the specified XPath expression, filter, and namespace map. The map is copied to protect against subsequent modification.

Parameters:
expression - the XPath expression to be evaluated
filter - the filter operation ({@link Filter#INTERSECT}, {@link Filter#SUBTRACT}, or {@link Filter#UNION})
namespaceMap - the map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.
Method Detail

getExpression

public String getExpression()
Returns the XPath expression to be evaluated.

Returns:
the XPath expression to be evaluated

getFilter

public XPathType.Filter getFilter()
Returns the filter operation.

Returns:
the filter operation

getNamespaceMap

public Map getNamespaceMap()
Returns a map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.

This implementation returns an {@link Collections#unmodifiableMap unmodifiable map}.

Returns:
a Map of namespace prefixes to namespace URIs (may be empty, but never null)


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.