This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.xml.crypto.dsig.spec
class XPathType.Filter

java.lang.Object extended by javax.xml.crypto.dsig.spec.XPathType.Filter
Enclosing class:
XPathType

public static class XPathType.Filter
extends Object

Represents the filter set operation.


Field Summary
static XPathType.Filter INTERSECT
          The intersect filter operation.
static XPathType.Filter SUBTRACT
          The subtract filter operation.
static XPathType.Filter UNION
          The union filter operation.
 
Method Summary
 String

          Returns the string form of the operation.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Field Detail

INTERSECT

public static final XPathType.Filter INTERSECT
The intersect filter operation.

SUBTRACT

public static final XPathType.Filter SUBTRACT
The subtract filter operation.

UNION

public static final XPathType.Filter UNION
The union filter operation.
Method Detail

toString

public String toString()
Returns the string form of the operation.

Overrides:
toString in class Object
Returns:
the string form of the operation


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.