This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


javax.xml.crypto.dsig.spec
class XSLTTransformParameterSpec

java.lang.Object extended by javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
All Implemented Interfaces:
TransformParameterSpec

public final class XSLTTransformParameterSpec
extends Object
implements TransformParameterSpec

Parameters for the XSLT Transform Algorithm. The parameters include a namespace-qualified stylesheet element.

An XSLTTransformParameterSpec is instantiated with a mechanism-dependent (ex: DOM) stylesheet element. For example:

   DOMStructure stylesheet = new DOMStructure(element)
   XSLTTransformParameterSpec spec = new XSLTransformParameterSpec(stylesheet);
 
where element is an {@link org.w3c.dom.Element} containing the namespace-qualified stylesheet element.


Constructor Summary

          Creates an XSLTTransformParameterSpec with the specified stylesheet.
 
Method Summary
 XMLStructure

          Returns the stylesheet.
 
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
 

Constructor Detail

XSLTTransformParameterSpec

public XSLTTransformParameterSpec(XMLStructure stylesheet)
Creates an XSLTTransformParameterSpec with the specified stylesheet.

Parameters:
stylesheet - the XSLT stylesheet to be used
Method Detail

getStylesheet

public XMLStructure getStylesheet()
Returns the stylesheet.

Returns:
the stylesheet


This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.