This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


Package java.security.spec

Interface Summary
AlgorithmParameterSpec A (transparent) specification of cryptographic parameters.
ECField This interface represents an elliptic curve (EC) finite field.
KeySpec A (transparent) specification of the key material that constitutes a cryptographic key.
 

Class Summary
DSAParameterSpec This class specifies the set of parameters used with the DSA algorithm.
DSAPrivateKeySpec This class specifies a DSA private key with its associated parameters.
DSAPublicKeySpec This class specifies a DSA public key with its associated parameters.
ECFieldF2m This immutable class defines an elliptic curve (EC) characteristic 2 finite field.
ECFieldFp This immutable class defines an elliptic curve (EC) prime finite field.
ECGenParameterSpec This immutable class specifies the set of parameters used for generating elliptic curve (EC) domain parameters.
ECParameterSpec This immutable class specifies the set of domain parameters used with elliptic curve cryptography (ECC).
ECPoint This immutable class represents a point on an elliptic curve (EC) in affine coordinates.
ECPrivateKeySpec This immutable class specifies an elliptic curve private key with its associated parameters.
ECPublicKeySpec This immutable class specifies an elliptic curve public key with its associated parameters.
EllipticCurve This immutable class holds the necessary values needed to represent an elliptic curve.
EncodedKeySpec This class represents a public or private key in encoded format.
MGF1ParameterSpec This class specifies the set of parameters used with mask generation function MGF1 in OAEP Padding and RSA-PSS signature scheme, as defined in the PKCS #1 v2.1 standard.
PKCS8EncodedKeySpec This class represents the ASN.1 encoding of a private key, encoded according to the ASN.1 type PrivateKeyInfo.
PSSParameterSpec This class specifies a parameter spec for RSA-PSS signature scheme, as defined in the PKCS#1 v2.1 standard.
RSAKeyGenParameterSpec This class specifies the set of parameters used to generate an RSA key pair.
RSAMultiPrimePrivateCrtKeySpec This class specifies an RSA multi-prime private key, as defined in the PKCS#1 v2.1, using the Chinese Remainder Theorem (CRT) information values for efficiency.
RSAOtherPrimeInfo This class represents the triplet (prime, exponent, and coefficient) inside RSA's OtherPrimeInfo structure, as defined in the PKCS#1 v2.1.
RSAPrivateCrtKeySpec This class specifies an RSA private key, as defined in the PKCS#1 standard, using the Chinese Remainder Theorem (CRT) information values for efficiency.
RSAPrivateKeySpec This class specifies an RSA private key.
RSAPublicKeySpec This class specifies an RSA public key.
X509EncodedKeySpec This class represents the ASN.1 encoding of a public key, encoded according to the ASN.1 type SubjectPublicKeyInfo.
 

Exception Summary
InvalidKeySpecException This is the exception for invalid key specifications.
InvalidParameterSpecException This is the exception for invalid parameter specifications.
 



This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.