This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


Package javax.crypto.spec

Provides classes and interfaces for key specifications and algorithm parameter specifications.

See:
          Description

Class Summary
DESedeKeySpec This class specifies a DES-EDE ("triple-DES") key.
DESKeySpec This class specifies a DES key.
DHGenParameterSpec This class specifies the set of parameters used for generating Diffie-Hellman (system) parameters for use in Diffie-Hellman key agreement.
DHParameterSpec This class specifies the set of parameters used with the Diffie-Hellman algorithm, as specified in PKCS #3: Diffie-Hellman Key-Agreement Standard.
DHPrivateKeySpec This class specifies a Diffie-Hellman private key with its associated parameters.
DHPublicKeySpec This class specifies a Diffie-Hellman public key with its associated parameters.
IvParameterSpec This class specifies an initialization vector (IV).
OAEPParameterSpec This class specifies the set of parameters used with OAEP Padding, as defined in the PKCS #1 standard.
PBEKeySpec A user-chosen password that can be used with password-based encryption (PBE).
PBEParameterSpec This class specifies the set of parameters used with password-based encryption (PBE), as defined in the PKCS #5 standard.
PSource This class specifies the source for encoding input P in OAEP Padding, as defined in the PKCS #1 standard.
PSource.PSpecified This class is used to explicitly specify the value for encoding input P in OAEP Padding.
RC2ParameterSpec This class specifies the parameters used with the RC2 algorithm.
RC5ParameterSpec This class specifies the parameters used with the RC5 algorithm.
SecretKeySpec This class specifies a secret key in a provider-independent fashion.
 

Package javax.crypto.spec Description

Provides classes and interfaces for key specifications and algorithm parameter specifications.

A key specification is a transparent representation of the key material that constitutes a key. A key may be specified in an algorithm-specific way, or in an algorithm-independent encoding format (such as ASN.1). This package contains key specifications for Diffie-Hellman public and private keys, as well as key specifications for DES, Triple DES, and PBE secret keys.

An algorithm parameter specification is a transparent representation of the sets of parameters used with an algorithm. This package contains algorithm parameter specifications for parameters used with the Diffie-Hellman, DES, Triple DES, PBE, RC2 and RC5 algorithms.

Package Specification

Related Documentation

For documentation that includes information about algorithm parameter and key specifications, please see:

This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.