This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.


Package javax.xml.crypto.dsig.spec

Interface Summary
C14NMethodParameterSpec A specification of algorithm parameters for a javax.xml.crypto.dsig.CanonicalizationMethod Algorithm.
DigestMethodParameterSpec A specification of algorithm parameters for a javax.xml.crypto.dsig.DigestMethod algorithm.
SignatureMethodParameterSpec A specification of algorithm parameters for an XML javax.xml.crypto.dsig.SignatureMethod algorithm.
TransformParameterSpec A specification of algorithm parameters for a javax.xml.crypto.dsig.Transform algorithm.
 

Class Summary
ExcC14NParameterSpec Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
HMACParameterSpec Parameters for the XML Signature HMAC Algorithm.
XPathFilter2ParameterSpec Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm.
XPathFilterParameterSpec Parameters for the XPath Filtering Transform Algorithm.
XPathType The XML Schema Definition of the XPath element as defined in the W3C Recommendation for XML-Signature XPath Filter 2.0:
XPathType.Filter Represents the filter set operation.
XSLTTransformParameterSpec Parameters for the XSLT Transform Algorithm.
 



This documentation differs from the official API. Jadeite adds extra features to the API including: variable font sizes, constructions examples, placeholders for classes and methods, and auto-generated “See Also” links. Additionally it is missing some items found in standard Javadoc documentation, including: generics type information, “Deprecated” tags and comments, “See Also” links, along with other minor differences. Please send any questions or feedback to bam@cs.cmu.edu.
This page displays the Jadeite version of the documention, which is derived from the offical documentation that contains this copyright notice:
Copyright 2008 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms. Also see the documentation redistribution policy.
The official Sun™ documentation can be found here at http://java.sun.com/javase/6/docs/api/.